Home Forums Support Widget Support EasyBlog Blank page or errors in the control panel PHP file

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • responsive-muse
    Keymaster
    Post count: 232
    #31065 |

    After following all installation steps, if you see a blank page or error page when visiting your control panel (inside your assets folder) you probably broke the PHP.

    You can break the file encoding even if you type everything correctly.

    To avoid breaking the file, you must use an advanced text editor. The best free ones are Sublime Text (Windows & Mac) and Notepad++ (Windows).

    You can download them at:
    https://notepad-plus-plus.org/download/v7.5.4.html
    https://www.sublimetext.com/

    Radu
    Participant
    Post count: 1
    #31446 |

    Hi!
    I downloaded EasyBlog free for testing.
    It seems to be a good thing, but I do not know why the images are not uploaded to the post content nor can I select an image for the thumbnail of each post.
    Also, if I change UN and Pass, nothing works:
    when I save, it automatically redirects to the easyblog.php page (which does not exist anymore since I changed its name).

    If this widget would work as well as the presentation from your site, I would be willing to buy the premium version
    I would appreciate if you would reply to this email.

    All the best,
    Radu

    responsive-muse
    Keymaster
    Post count: 232
    #31531 |

    Hi Radu,

    If you change the file name of the PHP file, you must change that highlighted word also.

    That means, if you have renamed your file to myblogfile.php, your line 29 should look like $pagename=”myblogfile”;

    Easyblog PHP settings

    About the problems when changing the username and password, please, read my previous msg, you are probably breaking the file encoding.

    About the images, once you have solved the previous issues, please, tell us if the problems continue.

    I hope this helps!

    peter
    Participant
    Post count: 3
    #32106 |

    Hi
    I configured easyblog.php with sublime, just name an password, nothing else, and get php errors. My server uses php7. What is going wrong? In the muse window the blog looks ok after linking to easyblog.php

    [LINK REMOVED]

    responsive-muse
    Keymaster
    Post count: 232
    #32111 |

    Hi Peter,
    The widget seems to work correctly, you would just need to remove that ugly warnings.
    Usually you can suppress PHP “warnings” and “notices” using your hosting control panel. They can also deactivate them for you if you submit a ticket to their support.

    peter
    Participant
    Post count: 3
    #32369 |

    Hi
    I don’t want to deactivate all php error messages for the whole server, sometimes they are useful.
    There are some bugs in your code. Do you fix that? Whats about the paid version? Same errors?

    responsive-muse
    Keymaster
    Post count: 232
    #32371 |

    Yo do not need to disable it in the whole server, your hosting should allow you to disable it only in some folders/domains.
    All we can do is checking your server to see if we are able to remove that notices by code, but we would need to access to your FTP server to analyze/fix the errors.
    If you wanna us to try, you can submit a ticket using the SUPPORT menu. My colleagues will ask you FTP credentials to access to your current site.
    Kind regards.

    peter
    Participant
    Post count: 3
    #33049 |

    I upgraded to php 7. Now it works well. Thankyou, I like this widget! (Could you please delete the Link in my previous post?)

    responsive-muse
    Keymaster
    Post count: 232
    #33053 |

    That’s great Peter, the link has been removed.
    Kind regards.

    Caroline
    Participant
    Post count: 4
    #33266 |

    Hi,

    I downloaded the Easy BLog and followed all the instructions.
    Used Notepad++ to change the code and uploaded everything to my server.

    However, when trying to create a post on the PHP dashboard, after clicking
    “Create” nothing happens.

    Thought the code could be possibly broken, so downloaded all the widget file again, and changed only the password part of PHP.
    Still no luck. Is there any way to solve this problem?

    Information:
    Windows 10 Home 1709
    Muse CC 2018.0
    Server PHP Compatible
    Tried Chrome and Explorer Browsers.

    Thanks in advance

    responsive-muse
    Keymaster
    Post count: 232
    #33273 |

    Hi Caroline,

    If you use the widget without editing anything in the file, (just download and use) does it works?

    So we can discard that editing the file is the problem.

    Kyra
    Participant
    Post count: 3
    #33419 |

    Hi!

    I have the same problem as Caroline.

    I bought the Easy Blog widget….
    I kept the username and password as it ist and it works…. almost… the picture won’t shown on my page but at the control panel.
    But when I change the username and password it won’t work anymore. I can’t add a new post.

    Additing a picture in a post is also not possible…

    Switching from Public yes to no is also not working… GREAT WIDGET! What a waste of money…

    • This reply was modified 4 months ago by  Kyra.
    • This reply was modified 4 months ago by  Kyra.
    Kyra
    Participant
    Post count: 3
    #33423 |

    and another problem….. when I click on a post, the site jumps to the beginning and you have to scroll down to read the post.

    responsive-muse
    Keymaster
    Post count: 232
    #33445 |

    Hi Kyra,

    I’m sorry for the inconvenience.

    If most of your problems appear after editing the username and password in the .PHP file, that means there was a mistake when editing them.

    Are you using Notepad++ or Sublime text editors as explained in the first msg?

    Anyway, since you are using the premium version, please, send us a support ticket using SUPPORT -> SUBMIT A TICKET

    Our support team will look at your problem and solve it.

    Regards,

    Caroline
    Participant
    Post count: 4
    #33486 |

    Hi, I tried using the downloaded version without changing anything.
    Still doesn’t work.

    What can I do to solve this problem?

    Thanks,
    Caroline

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.